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Introduction 
 
 
Welcome to Flame Painter. 
 
Flame Painter is a unique paint application that lets you easily create original artworks, light 
effects, unconventional design or fantastic backgrounds with flame brushes. 
It was created as an experimental project in my 'I am an Artist' series. The initial vision was to 
create an application where anyone could create something beautiful. It was made both as a 
tool for artists as well as for people without artistic skills who want to create something 
unique.  
Lack of inspiration and motivation are often the reasons why we people are not creative, 
however, the tools that we use can become the inspiration for creativity. I think that with tools 
which inspire you, everyone can be an artist. 
This is why Flame Painter was born. 
 
This manual covers the features of the application and tells you what you need to know to get 
painting. There is a range of flame brush parameters available, just experiment with different 
brush settings and maybe you’ll find a whole new creative way of self-expression. 
 
Thanks for purchasing Flame Painter. I hope you’ll have a great time painting! 
 
 
                Peter Blaškovič 
         creator of Flame Painter 

  



User Interface Window 
 

 

Tools Panel 
 
 
Brush – Select the Brush tool  
Eraser – Select the Eraser tool 
Fill – Select the Fill tool  
Zoom In – Zoom in on your artwork (at a maximum size 
of 200%). 
Zoom Out – Zoom out from your artwork (at a 
minimum size of 5%). 
Reset Zoom – Check the zoom value here. Press the 
button to reset the zoom to 100%. 
Undo - Undo the last painting operation you 
performed.  
Redo - Redo the last operation you undid. 
 
 

Brush 
 
There are three different painting modes: 
 
Flame – The classic flame painting mode. 
Follow – The stroke will follow the mouse more 
precisely. 
Ribbon – The ribbon painting mode. 
 
Blending - Color blending mode. There are three 
blending modes - Normal for regular painting, Lighten 
(additive mode) is usually for light effects and darker 
backgrounds and Darken (subtractive mode) for lighter 
background. 

Opacity - Brush opacity (0 - 100) 
 
 
Flame, Follow and Ribbon brush parameters 
 
These are parameters of the Brush tool for you to experiment with: 
 
Size - Brush Size (1 – 300) 
Span - Brush Width (0 – 10) 
Dist - Brush dots distance (1 – 20) - you can set this if the "Lines" is switched to "On" 
 
Soft - Brush Softness (1 – 100) 



Speed - Brush Speed (1 – 100) 
Center - Global Forces (0 - 100) 
Focus - Local Forces (0 – 100) 
Chaos - Very Chaotic Parameter (0 – 100) 
Noise - Crazy Noise Parameter (0-100) 
 
Fade - Fade In/Out Brush (0-10). Set the timing for fading in/out. 
 
Fill | Lines - Switch between "Fill" and "Lines" mode 
 
Detail - Brush Detail (1-4). Set the quality detail of the flame stroke. Use it if you want a smooth 
detailed stroke, or if you’ve set up a larger canvas size.  
Note: When setting the parameter higher, the painting can slow down, because it’s compute 
intensive.  
 
Antialiasing (AA) - Switch between "Normal Antialiasing" and "Supersmooth Antialiasing" 
Note: When setting the parameter to "Supersmooth Antialiasing", the application can slow 
down, because it’s more compute intensive than "Normal Antialiasing".  
 
 

 

Eraser 
 
Set the Eraser tool parameters: 
 
Size - Size of the eraser tool (1-200) 
Hardness - Hardness of the eraser tool (0-100) 
Step – Step of the eraser tool (0-100) 
Opacity - Opacity of the eraser tool (0-100) 

 
 
 

 
 
 

Fill 
 
You can fill the layer with "Color" or "Gradient" palette. 
If you choose the gradient, you can fill layer vertically or 
horizontally. 
 
Vertical |Horizontal - Switch between "Vertical" and 
"Horizontal" fill. 
 

 



Palette Panel 
 
 
Color | Gradient - Choose whether you want to paint or fill layer with one color or with 
gradient transition. 
 
 

Color 
 
Choose your brush color here. 
 
H - Brush hue (0 - 359) 
S - Brush saturation (0 - 255) 
L - Brush luminance (0 - 255) 
 
Palette - select brush color 
 
(+) (-) - add and remove colors from custom colors. 
 
Single click on color box opens a palette selector. 
The color you use for painting in Lighten or Darken 
mode might not appear exactly the same as you see at 
the "Brush Color". This is typical of the application and 
the Lighten / Darken painting modes. If you would like 
to have the exact color, choose Normal painting mode. 
 

 

Gradient 
 

Choose and setup your gradient transition.  
Click on the color button you want to change and select 
the color from palette. You can switch on/off the color 
you want to use in the gradient. 
 
Rotate - Rotate gradient transition. 
Flip - Flip gradient transition. 
 
H | S | L - Change hue, saturation and lightness for all 
colors in gradient. 
 
Set Gradient Length - Choose whether you want to use 
gradient for brush width or a length and set the gradient 
length. 
 
(+) (-) - add and remove colors and gradients from the 
lists.  



Brushes Panel 
 
 

Brush presets window, you can open or save your 
brush settings here. 
 
Use brush palette - use brush saved palette  
 
(+) (-) - add and remove brush presets from the list. 
 
To add new brush preset, click "Add brush" (+), paint 
yourself your brush icon, enter the brush name and 
click Save. 
A new brush will appear in Brushes menu immediately. 
 
You can Drag & Drop new brushes directly from 
Brushes webpage to application. Link to free brushes: 
http://www.escapemotions.com/products/flamepainter/bru
shes/index.php 
 
 
 

 
 

Layers Panel 
 

Use Layers panel window to edit and manipulate with 
layers. 
 
New Layer - Add new layer. 
New Vector Layer - Add new editable vector layer.   
This feature is available in Pro version. (More 
information about Vector Layers in the next chapter.) 
Duplicate Layer - Duplicate active layer or layers. 
Merge Layers - Merge more layers into one layer. 
Remove Layer - Delete active layer or more layers. 
 
Clear Layer - Clear the layer. 
 
You can convert Vector Layer to Bitmap from menu. 

 
Blending - Layer blending mode. 
Opacity - set the opacity of the layer 
Eye - Show or hide the active layer (next to layer icon). 

 

http://www.escapemotions.com/products/flamepainter/brushes/index.php
http://www.escapemotions.com/products/flamepainter/brushes/index.php


Editable Vector Layers - Pro version 
 

Vector layers have a great advantage of additional 
editing the painted strokes. In vector layer you can 
paint one brush stroke which you can additionally 
transform and edit. After painting a stroke you can 
change any brush parameter, blending mode, opacity, 
color and gradient palettes or change the whole brush 
preset for another one. It's very flexible edit mode if 
you would like additionally balance the parameters to 
set the perfect brush shape. 
 
Paint Tool - Paint a new brush stroke. You can paint 
one brush stroke on one vector layer. 
Edit Tool - Edit key vertices (yellow dots) and modify 
the created vector. Click on vertices (grey) to switch 
them to key vertices (yellow). 
Group Edit Tool - Edit group of key vertices (yellow 
dots). 
Add & Remove Tool - (shortcut: Cmd) Remove editable 
vertices from the flame line. 
Curve Transform - Resize, rotate and scale a brush 
stroke.  
Init Curve Transform - Resize, rotate and scale an initial 
curve for brush stroke. 

 
 
  



The Menu Bar 

 
File - Contains items related to loading, saving, exporting and publishing your paintings. 
Tools - Contains items related to the painting tools and the canvas. 
Layer - Contains items related to the layers. 
View - Contains items related to the viewport and user interface. 
Help - Contains items that let you get help on the application, or look for updates on website. 
 
 

File Menu 
 
The File Menu contains items related to your painting. They work as follows: 
 
New... - Open a dialog that allows you to create a new painting with new settings. 
Open... - Open a file dialog that allows you to load a painting from disk. 
Save... - Save your painting. If you have not saved it before, you are prompted to enter a name. 
Save As… - Save a copy of your current painting as a new one. 
 
Import… - Open a picture to new layer. Picture is resized to actual canvas size, but you can 
change it to any size. 
 
Publish… - Publish your painting to Flame Painter Gallery. Enter the name of the painting, 
optionally write a description and tags.  
 
For more information on creating, loading and saving your paintings, see the ‘Creating, Loading 
and Saving Paintings’ section later on in the manual. 
 
 

Tools Menu 
 
Brush - Select the Brush tool. 
Eraser - Select the Eraser tool. 
Fill - Select the Fill tool. 
 
Undo - Undo the last painting operation you performed. Number of undo-steps depends on 
your computer memory. Maximum number of undo steps is 100. 
Redo - Redo the last operation you undid. 
 
Show Cursor - Show or hide a cursor. 
Show Brush Dots - Show or hide brush dots. 
 
 
 
 
 



Layer Menu 
 
New Layer - Add new layer. 
New Vector Layer - Add new vector layer. 
Duplicate Layer - Duplicate active layer or layers. 
Merge Layers - Merge layers into one layer. 
Delete Layer - Delete active layer or layers. 
 
Show | Hide Layer - Show or hide the active layer. 
 
Tile Layer - Tiles layer horizontally and vertically. 
 
Clear Layer - Clear the layer. 
Convert to Bitmap - convert vector layer to bitmap layer (only pro edition). 
 
 

View Menu 
 
Zoom In - Zoom in on your artwork (at maximum size of 200%). 
Zoom Out - Zoom out from your artwork (at a minimum size of 5%). 
Zoom 100% - Check up a zoom value. Press the button to reset the zoom to 100%. 
 
Stay on top - Application will stay always on a top of other applications. 
Fullscreen – Switch the application window to full screen mode. (Press Esc to quit). 
Presentation mode - Full screen mode without menu (Press Esc to quit). 
 
 

Help Menu 
 
Help - Open this document. 
Flame Painter Website - Link to website: www.escapemotions.com/products/flamepainter 
 
Publish Preferences... - A sub-menu is containing Gallery preferences. 
 
Show Brushes Folder… - Show folder where brushes are saved. 
  
  



Creating, Loading and Saving Paintings 
 
 

Creating a New Painting 

 
To create a new painting, select the New... option from the File Menu, or press Cmd-N. When 
you do this, the New file panel appears. This panel lets you set the size of your new painting, 
and set up the settings of the canvas you’re going to be painting on. In “Picture Size Info” 
section you can check the picture print size. 
 
The Color Button lets you select the color of the background, including the choice of the preset 
Black or White background.  
 
Finally, click OK to create a new painting, or Cancel if you decide not to. 
 
 

Opening a Painting 

 
To open a painting, select the Open... option from the File Menu, or press Cmd-O. This panel 
lets you open a picture or previously saved artwork and set up the properties.  
 
Finally, click OK to open the painting, or Cancel if you decide not to. 
 
You can also Drag and Drop picture directly from any source - folder, browser or website and it 
opens as a new layer. 
 
 

Saving a Painting 

 
To save your painting, use the Save... option in the File Menu. The native format is a FPA file 
format, which contains all the information about the artwork and the layers. Use this format if 
you want to carry on with the painting later.  
You can also choose another file formats, but these don't contain all the artwork information 
and may not be opened correctly (background color may be different, or transparency might 
not be saved in JPG format).  
 
If you wish to save your painting with specific settings or in a form that can be read by other 
applications, use the Save... option in the File Menu. It allows you to save your painting as a 
PNG, TIF, BMP, or JPG file.  
 
Finally, click OK to save the painting or Cancel if you decide not to. 
  



Publish a Painting to Gallery 
 
 

Creating a Gallery account 
 
To publish your artworks, firstly you have to create an account. To create an account you have 
two options:  
 
From application: 
Create your Gallery account from Flame Painter's menu Help->Publish Preferences. Set Your 
name, Email ("Your ID") and Password to gallery and optionally a link to your Website. 
 
From website: 
On Flame Painter Gallery website press login -> Create Account and enter “Your ID” 
(registration email). We will send you a Password, which you can change later on. 
Note: You can find "Your ID" in Flame Painter's menu Help->About Flame Painter. If "Your ID" 
does not exist, enter your active email. 
 
 

Publish artwork from Flame Painter to Gallery 
 
To publish your painting, use the Publish... option in the File Menu. Enter the Artwork Name, a 
picture Description and Tags. Click Publish button.  Your picture will be published on Flame 
Painter Gallery website (www.escapemotions.com/gallery) where you can edit pictures later 
on. 
 
 

Edit your profile and artworks in Gallery 
 
If you have already created an account, go to Gallery website, press login and enter "Your ID" 
and Password. 
In Edit Pictures section you can edit your artworks name, description, tags and other settings. 
In My Profile section you can change your Password. 
 

  

http://www.escapemotions.com/gallery


Keyboard Shortcuts: 
 
 
New...     Cmd-N 
Open...    Cmd-O 
Save    Cmd-S 
Save As...   Cmd-Shift-S 
Publish...   Cmd-P 
Quit    Cmd-Q 
 
Undo    Cmd-Z 
Redo    Cmd-Shift-Z 
 
Brush     Q 
Eraser     E 
Fill    F 
 
Increase Value +1  Up 
Decrease Value  -1  Down 
 
Increase Value +10  Pg Up 
Decrease Value -10  Pg Down 
 
Cursor Show | Hide  Alt-C 
Brush Dots Show | Hide Alt-D 
 
Clean Layer   Del 
 
Move a Canvas  Right MouseButton or Space Bar + LMB 
 
Zoom In    Cmd - + 
Zoom Out   Cmd - - 
Zoom 100%   Cmd - 0 
Zoom In | Out   Alt + Mouse Scroll 
 
Help    F1 
 
 
Professional version: 
 
Paint Tool   1 
Edit Tool   2 
Group Edit Tool  3 
Add & Remove Tool  4 
Curve Transform  5 
Init Curve Transform  6  



Personal versus Professional Version 
 
 
Personal version is more suitable for users who want to have complete creative tool, but do 
not need to use Vector Layers and do not sell the pictures created or modified in Flame 
Painter. The license allows to install Flame Painter on multiple computers for single user for the 
personal non-commercial use or non-profit activities. 
 
Professional version is better for professionals and advanced users who need Vector Layers, 
unlimited number of Layers or Supersmooth Antialiasing. The license allows to install Flame 
Painter on a one computer for commercial or non-commercial use. 
 
For more details please read the complete Software License Agreement. 
  
 
 
 
 

  



Copyright & Credits 
 
 
Flame Painter © 2012-2013 Escape Motions, s.r.o 
Flame Painter © 2009-2012 Peter Blaškovič 
 
 

Flame Painter Team: 
 
Peter Blaškovič, Jozef Bardík, Rastislav Hornák, Michal Fapšo, Rastislav Piovarči, Veronika 
Klimeková, Andrea Vachová 
 
 

Special Thanks to: 
 
Everyone who contributed with ideas, suggestions, or helped to finalize Flame Painter, 
especially to Gabika Ambrušová, Cara, Daniel Innes, Tanya Hayman, Oto Kona, Tomáš Lancz, 
Lukáš Lancz, Tony Lloyd, Tomáš Mišura, Andrei Oprinca, Martin Surovček, Daniel Streidt, 
Roman Urbášek. 
 
User Interface Icons: "Batch" by Adam Whitcroft 
 
 

Libraries: 
 
This application has been developed with the following libraries: 
Qt 4.8 - LGPL license (2.1) - http://qt-project.org/downloads/ 
QuaZIP - LGPL license (2.1) - http://sourceforge.net/projects/quazip/ 
CryptoPP - Boost Software License (1.0) - http://www.cryptopp.com/ 
 
 
Thanks to God for all creative ideas. 
 
 
 
 

http://qt-project.org/downloads
http://sourceforge.net/projects/quazip/
http://www.cryptopp.com/

