
Amberlight Manual 
v.1.2  

 
 

 
 
 
Welcome to Amberlight! 
 
Amberlight is a unique art tool that creates beautiful computer generated images. A millions of 
particles are flying through your canvas and you can drive them with the special Amber fields. 
No matter if you are an advanced artist or a complete art beginner, playing and experimenting 
with its tools you are able to create fantastic images. In the world of computer art this is a one-
of-a-kind tool that will broaden your artistic horizons and unveils a very new art experience. 
 
Similarly to Flame Painter, Amberlight was originally created as an experimental project in my 
'I am an Artist' series. The initial vision was to create the application where anyone could 
create original artworks. It was made both as a tool for artists as well as for people without 
artistic skills who want to create something unique.  
Lack of inspiration and motivation are often the reasons why we people are not creative, 
however, I believe the tools that we use can become the inspiration for creativity. I think that 
with tools which inspire you, everyone can be an artist. 
This manual covers the features of the application and tells you what you need to know to use 
Amberlight and find a whole new creative way of self-expression. 
 
Thanks for purchasing Amberlight. We hope you’ll have a great time! 
 
              Peter Blaškovič 
         creator of Amberlight  



User Interface Window 
 

 

Scene Panel 
 

Zoom Out - Zoom out from your artwork (at a 
minimum size of 5%). 
Zoom In - Zoom in on your artwork (at a maximum 
size of 800%). 
Reset Zoom - Check the zoom value here. Press the 
button to reset the zoom to 100%. 
 
Edit - Switch to Edit fields mode. 
Fields - Set the number of fields (1-12). 
Delete field - Delete selected field. 
Random - Random scene and fields. 
Clear - Clear scene. 
Render - Render scene. 
Step - Set the number of render steps - iterations. If 
you would like to have smoothly rendered scene, set 
it to 10000 or even to 100000. 
Use actual value - Use the value from Step as a final 
value. 
 
 
Contrast Curve 
 
There are four different contrast settings: 
 
Base - Set the base of the contrast curve - shadows. 
Peak - Set the peaks of the curve - highlights. 
Limit - Set the limit of the curve peak.  
 
 Opacity - Amberlight picture opacity (0 - 100). 
 
 
Filter 
 
Filter parameters to experiment with: 
 
Tint - Turn on and off tint gradient, rotate tint and 
set the tint color and radius (0 – 100). 
Glow - Turn on and off glow effect. 
 Radius - Set the glow radius (0 – 100). 
 Strength - Set the glow strength (0 – 100).  



Palette Panel 
 
 
Color | Gradient - Choose whether you want one color or gradient color transition. 
 
 

Color 
 
Choose the color for scene rendering here. 
 
H - Hue (0 - 359) 
S - Saturation (0 - 255) 
L - Luminance (0 - 255) 
 
Palette - Select the color. 
 
Use as Gradient - Use the color in a gradient color 
transition. 
 
(+) (-) - Add and remove colors from custom colors. 
 
Single click on color box opens a palette selector. 
 
 

 
 

Gradient 
 

Choose and setup your gradient transition for scene.  
Click on the color button you want to change and 
select the color from palette. You can switch on/off 
the color you want to use in the gradient. 
 
Shift - Shift gradient colors to right. 
Flip - Flip gradient. 
Invert - Invert colors in gradient. 
 
Gradient to Black - Change gradient transition to 
black color.  
Gradient to White - Change gradient transition to 
white color. 
 
H | S | L - Change hue, saturation and lightness for all 
colors in gradient. 
 
(+) (-) - Add and remove gradients from the lists.  



Layers Panel 
 

Use Layers panel window to edit and manipulate 
with layers. 
 
Blending - Layer blending mode. 
Opacity - Set the opacity of the layer (0 - 100). 
Eye - Show or hide the active layer. 
Background Color - Show / Hide Background Color 
and select its color. 
 
Import Image - Import the second image for 
composition.  
Clear Layer - Clear the Amberlight or Image layer. 
 

 

Edit Fields 
 

Press Edit button in Scene panel or Left Mouse Button on a canvas to edit fields. You can set 
number of fields in Scene panel from 1 to 12. Every field is represented as a circle with position 
and 3 parameters. With these parameters you can set how the fields will influence particles. 
 

Field parameters: 
 
Center Position - (A) - Press LMB (Left Mouse Button) 
on a center circle button and set position of the field 
on a scene. 
 
Force - (B) - Press LMB on a button and set the force 
of the field with moving it left and right. Right from 
the center has the field positive force (+) and on a left 
from the center is negative force (-). 
 
Intensity - (C) - Press LMB on a button and set the 
field intensity with moving it up and down. Distance 
from the center sets the intensity value. Up from the 
center is higher and down is lower. With this 
parameter you change how intense is the influence of 
the field on the particles. 
 

Cut-off - (D) - Press LMB on a button and set the field cut-off with moving it down from the 
circle center. Distance from the circle center sets the distance, where the particles will stop 
from the field. 
 
Press Ctrl / Cmd in Edit Mode to pan, zoom or rotate all fields. More info in Shortcuts section.  



The Menu Bar 
 
File - Contains items related to loading, saving, exporting and publishing your pictures. 
Scene - Contains items related to editing tools and the canvas. 
Filter - Contains items related to the image filters. 
View - Contains items related to the viewport.  
Windows - Contains items related to dock panels and user interface. 
Help - Contains items that let you get help on the application, or look for updates on website. 
 
 

File Menu 
 
The File Menu contains items related to your canvas. They work as follows: 
 
New... - Open a dialog that allows you to create a new scene with new settings. 
Open... - Open a file dialog that allows you to load a artwork from disk. 
Save... - Save your artwork. If you have not saved it before, you are prompted to enter a name. 
Save As… - Save a copy of your current artwork as a new one. 
 
Quit - Close the application. (Only on Windows) 
  
For more information on creating, loading and saving your artworks, see the ‘Creating, Loading 
and Saving Images’ section later on in the manual. 
 
 

Scene Menu 
 
Canvas Size… - Open a dialog that allows you to set a scene size. You can select if you want to 
Keep aspect ratio of the scene and if you want to Scale fields too. 
 
Edit - Edit fields, their position and parameters - Force, Intensity and Cut-off. 
Random - Random scene and fields parameters. 
Clear - Clear scene. 
Render - Render scene. 
 
Import Image... - Import a second image to layer. Image is resized to fit the actual canvas size, 
but you can change it to any size. 
 
 

Filter Menu 
 

Tint - Turn on and off Tint filter. Set the tint color and Radius from Scene dock panel. 
Glow - Turn on and off Glow filter. Set the glow Radius and Strength from Scene dock panel. 
Tile - Tiles layer horizontally and vertically. 
 



View Menu 
 
Zoom In - Zoom in on your artwork (at maximum size of 800%). 
Zoom Out - Zoom out from your artwork (at a minimum size of 5%). 
Zoom 100% - Check up a zoom value. Press the button to reset the zoom to 100%. 
 
 

Window Menu 
 
The Window Menu contains items related to dock panels and interface. They work as follows: 
 
Scene - Show or hide Scene dock panel. 
Palette - Show or hide Palette dock panel. 
Layers - Show or hide Layers dock panel. 
 
Stay on Top - Application will stay always on a top of other applications. 
 
 

Help Menu 
 
Help - Open this document. 
Send Feedback... - Send us feedback if you have any problem, some idea or just like the 
program. Enter your email and message. 
Amberlight Website - Link to website: amberlight.escapemotions.com 
About Amberlight - Get some basic information on Amberlight, copyright and credits. (In Help 
menu only on Windows.) 
Show Gradients Folder - Show folder where gradients are saved. 
  



Creating, Loading and Saving Images 
 
 

Creating a New Painting 
 
To create a new artwork, select the New... option from the File Menu. When you do this, the 
New file panel appears. This panel lets you set the size of your new canvas, and set up the 
settings you’re going to use. In “Picture Size Info” section you can set the picture print 
resolution in DPI. 
 
You can select the color of the background selecting Custom… in a scroll-down menu. The 
choice of the preset Black, White and None (transparent) background is available as well.  
 
Finally, click OK to create a new artwork, or Cancel if you decide not to. 
 
 

Opening a Painting 
 
To open a painting, select the Open... option from the File Menu. This panel lets you open a 
picture (PNG, JPG, BMP, TIFF) or previously saved artwork (in AMB file format) and set up the 
properties. When opening a previously saved artwork, the image will be again re-rendered. 
 
Finally, click OK to open the painting, or Cancel if you decide not to. 
 
You can also Drag and Drop picture directly from any source - folder, browser or website and it 
opens into the "Image" layer. 
 
 

Saving a Painting 
 
To save your artwork, use the Save... option in the File Menu. The native format is an AMB file 
format, which contains all the information about the artwork and the layers. Use this format if 
you want to carry on with the painting later. When you open a saved artwork later, the image 
will be again re-rendered. 
 
You can also choose another file formats, but these don't contain all the artwork information 
and may not be opened correctly (background color may be different, or transparency might 
not be saved in JPG format).  
 
If you wish to save your painting with specific settings or in a form that can be read by other 
applications, use the Save... option in the File Menu. It allows you to save your painting as a 
PNG, JPEG, BMP or TIFF file.  
 
Finally, click OK to save the painting or Cancel if you decide not to. 
  



Publish a Painting to Gallery 
 
 

Creating a Gallery account 
 
To publish your artworks, firstly you have to create an account. To create an account you have 
two options:  
 
From application: 
Create your Gallery account from application menu File -> Publish Preferences. Set Your name, 
Email ("Your ID") and Password to gallery and optionally a link to your Website. 
 
From website: 
On Gallery website press login -> Create Account and enter “Your ID” (registration email). We 
will send you a Password, which you can change later on. 
Note: You can find "Your ID" in menu Help ->About Amberlight. If "Your ID" does not exist, 
enter your active email. 
 
 

Publish artwork from Amberlight to Gallery 
 
To publish your painting, use the Publish... option in the File Menu. Enter the Artwork Name, a 
picture Description and Tags. Click Publish button.  Your picture will be published on Gallery 
website (www.escapemotions.com/gallery) where you can edit pictures later on. 
 
 

Edit your profile and artworks in Gallery 
 
If you have already created an account, go to Gallery website, press login and enter "Your ID" 
and Password. 
In Edit Pictures section you can edit your artworks name, description, tags and other settings. 
In My Profile section you can change your Password. 

  

http://www.escapemotions.com/gallery


Keyboard Shortcuts: 
 
 
    Windows    Mac OS 
 
New...     Ctrl-N     Cmd-N 
Open...    Ctrl-O     Cmd-O 
Save    Ctrl-S     Cmd-S 
Save As...   Ctrl-Shift-S    Cmd-Shift-S 
Quit    Ctrl-W     Cmd-Q 
 
Size...    Ctrl-E     Cmd-E 
 
Edit Mode   E     E 
Edit all fields in Edit Mode  Ctrl     Cmd 
Pan Fields in Edit mode Ctrl + RMB    Cmd + RMB 
Zoom Fields in Edit mode Ctrl + Mouse Scroll or LMB  Cmd + Mouse Scroll or LMB 
Rotate Fields in Edit mode Ctrl + LMB    Cmd + LMB 
 
Increase Value +1  Up     Up 
Decrease Value  -1  Down     Down 
Increase Value +10  Pg Up     Pg Up 
Decrease Value -10  Pg Down    Pg Down 
 
Move a Canvas  Right MouseButton (RMB) or Space Bar + LMB 
 
Zoom In    Ctrl - +     Cmd - + 
Zoom Out   Ctrl - -     Cmd - - 
Zoom 100%   Ctrl - 0     Cmd - 0 
Zoom In | Out   Mouse Scroll or Alt + Mouse Scroll 
 
Help    F1     Cmd + ? 
  



Copyright & Credits 
 
 
Amberlight © 2013-2014 Escape Motions, s.r.o 
Amberlight © 2009-2012 Peter Blaškovič 
 
 
Amberlight Team: 
 
Peter Blaškovič, Michal Fapšo, Veronika Klimeková, Andrea Vachová 
 
 
Special Thanks to: 
 
Everyone who contributed with ideas, suggestions, or helped to finalize Amberlight, especially 
to Jozef Bardík, Jaroslav Kaša, Daniel Innes, Tomáš Lancz, Harvey Bunda, Devraj Baruah, Rana 
Dias, Nigel Brewster, Jim Kanter, Rastislav Piovarči, Gregorii Trombo.  

Translation and corrections: Tanya Hayman, Veronika Klimeková, Marta Fernandez, Andrea 
Vachová, Irene Briz. 

User Interface Icons: "Batch" by Adam Whitcroft 
 
 
Libraries: 
 
This application has been developed with the following libraries: 
Qt 4.8 - LGPL license (2.1) - http://qt-project.org/downloads/ 
QuaZIP - LGPL license (2.1) - http://sourceforge.net/projects/quazip/ 
CryptoPP - Boost Software License (1.0) - http://www.cryptopp.com/ 
 
 
Thanks to God for all creative ideas.  

http://qt-project.org/downloads
http://sourceforge.net/projects/quazip/
http://www.cryptopp.com/


Amberlight End-User Software License Agreement  
 
 
Copyright © 2013-2014 Escape Motions, s.r.o. All Rights Reserved. 
Copyright © 2009-2012 Peter Blaškovič. All Rights Reserved. 
 
This license is a legal agreement between you and Escape Motions for the use of Amberlight 
software (the "Software"). By downloading, installing, copying, or otherwise using the 
Software, you acknowledge that you have read terms and conditions of this license, 
understand them, and agree to be bound by them. If you do not agree with these terms and 
conditions, Escape Motions is unwilling to license the Software to you, and you are not 
authorized and may not use the Software. 
 
 
Permitted Use  
 
You may install the Software on multiple computers provided that not more than one of those 
computers is in use simultaneously and that those computers are solely for your own personal 
use. 
The Software may be installed on a computer that is for multiple users but it may not be 
installed on more than one computer regardless of whether those computers are operated 
simultaneously or not. 
Users may use the Software for commercial or for-profit activities as well as for personal, non-
commercial, or non-profit activities.  
 
You may not remove the copyrights notices from the Software. You may make one (1) copy of 
the Software for back-up or archival purposes. 
 
 
Restrictions  
 
This is a SINGLE COPY SOFTWARE LICENSE. The Software is copyrighted and protected by law 
and international treaty.  This is a license, not a transfer of title, and unless you have been 
granted prior, written consent from Escape Motions you may not:  
a, Reproduce, distribute, or transfer the Software, or portions thereof, to any third party.  
b, Sell, rent, lease, assign, or sublet the Software or portions thereof.  
c, Grant rights to any other person.  
d, Modify, decompile, reverse engineer, disassemble, or create derivative works based on the 
Software or the documentation in whole or in part.  
e, Use the Software in violation of any international law or regulation.  
 
You must not intentionally or unintentionally make the Software available on any web server, 
ftp server, file sharing network, shared directory, or other location where any other person can 
acquire a copy of the Software. You are responsible for keeping the Software safe from being 
copied by others. 
 



 
Display of Copyright Notices  
 
All copyright and proprietary notices and logos within the Software files must remain intact.  
 
 
Indemnity  
 
You agree to indemnify and hold harmless Escape Motions for any third-party claims, actions or 
suits, as well as any related expenses, liabilities, damages, settlements or fees arising from your 
use or misuse of the Software, or a violation of any terms of this license.  
 
The Software may contain technical inaccuracies or typographical errors, so changes and/or 
updates may be affected without notice. Escape Motions may also make improvements and/or 
other changes to the Software at any time without notice.   
 
 
Disclaimer Of Warranty  
 
THE SOFTWARE IS PROVIDED \"AS IS\", WITHOUT WARRANTY OF ANY KIND, EXPRESSED OR 
IMPLIED,  AS TO THE SOFTWARE OR ITS OPERATION, INCLUDING, BUT NOT LIMITED TO, 
WARRANTIES OF QUALITY, PERFORMANCE, NON-INFRINGEMENT, MERCHANTABILITY, OR 
FITNESS FOR A PARTICULAR PURPOSE.  FURTHER, PETER BLASKOVIC DOES NOT WARRANT 
THAT THE SOFTWARE OR ANY RELATED SERVICE WILL ALWAYS BE AVAILABLE.  
 
 
Limitations Of Liability  
 
YOU ASSUME ALL RISK ASSOCIATED WITH THE INSTALLATION AND USE OF THE SOFTWARE. IN 
NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS OF THE SOFTWARE BE LIABLE FOR 
CLAIMS, DAMAGES OR OTHER LIABILITY ARISING FROM, OUT OF, OR IN CONNECTION WITH 
THE SOFTWARE. LICENSE HOLDERS ARE SOLELY RESPONSIBLE FOR DETERMINING THE 
APPROPRIATENESS OF USE AND ASSUME ALL RISKS ASSOCIATED WITH ITS USE, INCLUDING 
BUT NOT LIMITED TO THE RISKS OF PROGRAM ERRORS, DAMAGE TO EQUIPMENT, ANY LOST 
PROFITS, BUSINESS INTERRUPTION, LOSS OF DATA OR SOFTWARE PROGRAMS, OR 
UNAVAILABILITY OR INTERRUPTION OF OPERATIONS. 
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