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Introduction 
 
 
Welcome to Flame Painter. 
 
Flame Painter is a unique paint application that lets you easily create original artworks, light 
effects, unconventional design or fantastic backgrounds with flame brushes. 
 
It was created as an experimental project in my 'I am an Artist' series. The initial vision was to 
create an application where anyone could create something beautiful. It was made both as a 
tool for artists as well as for people without artistic skills who want to create something 
unique.  
 
Lack of inspiration and motivation are often the reasons why we people are not creative, 
however, the tools that we use can become the inspiration for creativity. I think that with tools 
which inspire you, everyone can be an artist. 
This is why Flame Painter was born. 
 
This is the third version of Flame Painter. There are many new features included - Flame 
Painter Connect - a Photoshop plug-in which works as a live link between Flame Painter and 
Photoshop, ability to use Wacom tablet pressure pen and Leap Motion camera, a smooth 
import and export of layered PSD and SVG vector files. Multi-core engine, new high resolution 
renderer and Photoshop blending modes have made this software a powerful tool for creating 
professional artworks. 
 
This manual covers the features of the application and tells you what you need to know to get 
painting. There is a range of flame brush parameters available, just experiment with different 
brush settings and maybe you’ll find a whole new creative way of self-expression. 
 
Thanks for purchasing Flame Painter. I hope you’ll have a great time painting! 
 
 
                Peter Blaškovič 
         creator of Flame Painter 
  



User Interface Window 
 
 

 

Tools Panel 
 
 

Brush - Select the Brush tool  
 
Pen - Select the Pen tool  
 
Eraser - Select the Eraser tool 
 
Fill - Select the Fill tool  
 
Transform - Move and resize selected layer 
 
Edit Vector Layer - Edit mode for selected  
vector layer  

 
Zoom Out - Zoom out from your artwork (at a 
minimum size of 5%). 
Zoom In - Zoom in on your artwork (at a 
maximum size of 800%). 

Reset Zoom - Check the zoom value here. 
Press the button to reset the zoom to 100%. 

Undo - Undo the last painting operation you   
performed.  
Redo - Redo the last operation you undid. 
 

 
 
 
 
 
 

 
 
 
 
 
 
 
 
 



Brush 
 
There are three different painting modes: 
 

Flame - The classic flame painting mode. 
 
Follow - The stroke will follow the mouse more precisely, a line-based brush. 
 
Ribbon - The ribbon painting mode, a stroke spreads a bit wider. 
 

 
Blending - Color blending mode. There are three blending modes:  
- Normal for regular painting,  
- Lighten (additive mode) is usually for light effects and darker backgrounds and  
- Darken (subtractive mode) for lighter backgrounds. 
Opacity - Brush opacity (0 - 100) 
 
Flame, Follow and Ribbon brush parameters 
 
These are parameters of the Brush tool for you to experiment with: 
 
Size - Brush Size – number of painting brush dots (1 – 300) 
Span - Brush Width (0 – 10) 
Dist - Distance between brush dots (1 – 20) - you can set this if the "Lines" is switched to "On" 
Soft - Brush Softness (1 – 100) - more global effect of the brush 
Speed - Brush Speed (1 – 100) - brush reaction time; the higher speed, the more precise brush 
Center - Global Forces (0 - 100) 
Focus - Local Forces (0 – 100) 
Chaos - Very Chaotic Parameter (0 – 100) - how chaotically brush dots oscillate around a brush 
Noise - Crazy Noise Parameter (0-100) - the higher number, the brush is more noisy. 
 
All these parameters are in mutual correlation. Each setting influences how a result brush will 
look like. 
 
Fade - Fade In/Out Brush (0-10). Set the timing for fading in/out. 
 

Fill | Lines - Switch between "Fill" and "Lines" mode. 
 

Detail - Brush Detail (1-4). Set the quality detail of the flame stroke. Use it if you want a smooth 
detailed stroke, or if you’ve set up a larger canvas size.  
Note: It’s compute-intensive parameter; when setting the parameter higher, the painting can 
slow down.  
 

Antialiasing (AA) - Switch between "Normal Antialiasing" and "Supersmooth 
Antialiasing". Note: When setting the parameter to "Supersmooth Antialiasing", the 

application can slow down, because it’s more compute-intensive than "Normal Antialiasing". 
This feature is available in Pro edition. 



Pen 
 
Set the Pen tool parameters: 
 
Blending - Color blending mode. There are three 
blending modes  
- Normal for regular painting,  
- Lighten (additive mode) is usually for light effects and 
darker backgrounds and  
- Darken (subtractive mode) for lighter backgrounds. 
Size - Size of the Pencil Brush tool (1-200) 
Hardness - Hardness of the Pencil Brush tool 
(0-100) 
Step - Step of the Pencil Brush tool (0-100) 
 Opacity - Brush opacity (0 - 100) 
 

Use only with Color. Gradient transitions are not available in Pencil Brush tool. 
 
 
 

Eraser 
 
Set the Eraser tool parameters: 
 
Size - Size of the eraser tool (1-200) 
Hardness - Hardness of the eraser tool (0-100) 
Step - Step of the eraser tool (0-100) 
Opacity - Opacity of the eraser tool (0-100) 
 
 
 
 
 
 

 
Fill 
 
You can fill the layer with "Color" or "Gradient" palette. 
If you choose the gradient, you can fill layer vertically 
or horizontally. 
 
Vertical |Horizontal - Switch between "Vertical" and 
"Horizontal" fill. 
 

 
 



Transform Layer 
 
Move and scale selected layer. Click OK to accept 
changes, or Cancel if you decide not to.  
If you would like to transform and edit Vector Layer 
(available in Pro edition), press "Edit Vector Layer" 
button. 
 
 

 
Edit Vector Layer - Pro edition 
 

Paint Tool - Paint a new brush stroke. You can 
paint one brush stroke on one vector layer. 
Edit Tool - Edit key vertices (yellow dots) and 
modify the created vector. Click on vertices 
(grey) to switch them to key vertices (yellow). 
Group Edit Tool - Edit group of key vertices 
(yellow dots). 
Add & Remove Tool - Remove editable vertices 
from the flame line. (shortcut: Ctrl on 
Windows/Cmd on Mac OS) 

 
Curve Transform - Resize, rotate and scale a brush stroke. 
  
Init Curve Transform - Resize, rotate and scale an initial curve for brush stroke. 
 

Vector layers have a great advantage of additional editing the painted strokes. In vector layer 
you can paint one brush stroke which you can additionally transform and edit. After painting a 
stroke you can change any brush parameter, blending mode, opacity, color and gradient 
palettes or change the whole brush preset for another one. It's very flexible edit mode if you 
would like to balance the parameters to get the perfect brush shape. 
 
Note: Please be aware that after creating a new stroke in a vector layer the previous one is 
deleted. A new vector layer for each editable stroke is recommended. 
 
  



Palette Panel 
 
 
Color | Gradient - Choose whether you want to paint or fill layer with one color or with 
gradient transition. 
 
 

Color 
 
Choose your brush color here. 
 
H - Brush hue (0 - 359) 
S - Brush saturation (0 - 255) 
L - Brush luminance (0 - 255) 
 
Palette - select brush color 
 
(+) (-) - add and remove colors from custom colors. 
 
Single click on color box opens a palette selector. 
The color you use for painting in Lighten or Darken 
mode might not appear exactly the same as you see at 
the "Brush Color". This is typical of the application and 
the Lighten / Darken painting modes. If you would like 
to have the exact color, choose Normal painting mode. 
 

 
Gradient 

 
Choose and setup your gradient transition.  
Click on the color button you want to change and 
select the color from palette. You can switch on/off the 
color you want to use in the gradient. 
 
Rotate - Rotate gradient transition. 
Flip - Flip gradient transition. 
H | S | L - Change hue, saturation and lightness for all 
colors in gradient. 
 
Set Gradient Length - Choose whether you want to use 
gradient for brush width or length and set the gradient 
length (1-10). The higher number, the gradient colors 
change more frequently. 
 
(+) (-) - add and remove colors and gradients from the 
lists.  



Brushes Panel 
 
 
Brush presets window, you can open or save your brush settings here. 
 

Use palette - Use palette saved in brush.  
Use blend mode - Use blend mode (normal, lighten or 
darken) which is saved in brush.  
 
Share Brush - upload your brush to the online Brushes 
Gallery. Click Yes to confirm. 
 
(+) (-) - add and remove brush presets from the list. 
 
To add new brush preset, click "Add brush" (+), paint 
yourself your brush icon, enter the brush name and 
click Save. 
A new brush will appear in Brushes menu 
immediately. 
 
Note: When saving brush in “Darken“ mode, only 
white background is available. When saving brush in 
“Lighten“ mode, only black background is available. 

 
 
To download more free brushes, follow the link, and drag & drop them from browser to Flame 
Painter window: 
http://www.escapemotions.com/products/flamepainter/brushes/index.php 
 
Note: Some browsers cannot transfer brushes’ metadata. If drag & drop from the browser does 
not work, use other browser for the drag & drop function, or download the brush from the 
above link to the folder, which can be found from Flame Painter's menu: "Help" -> "Show 
Brushes Folder" -> "Brushes". All brushes, which are in the “Brushes“ folder, will appear in the 
Brushes Panel.  
Manual on how to drag & drop and how to download the brushes can be found in FAQ's section 
on our website:  
https://www.escapemotions.com/products/flamepainter/support.php. 
 
 
 
 
 
 
 
 
 
 

http://www.escapemotions.com/products/flamepainter/brushes/index.php
https://www.escapemotions.com/products/flamepainter/support.php


Layers Panel 
 
 

Use Layers panel window to edit and manipulate with layers. 
 

Blending - 22 Photoshop blending modes: Normal, 
Darken, Multiply, Color Burn, Linear Burn, Lighten, 
Screen, Color Dodge, Linear Dodge, Overlay, Soft Light, 
Hard Light, Vivid Light, Linear Light, Pin Light, Hard Mix, 
Difference, Exclusion, Hue, Saturation, Color, 
Luminosity and Subtract mode. 
Opacity - Set the opacity of the layer (0-100). 

 
Eye - Show or hide the active layer (next to layer 
icon). 
Clean Layer - Clear layer content (shortcut Del). 
 
Export to "PS" - Export selected layer to 
Photoshop. 
You can find more information about Flame 
Painter Connect - the Photoshop Plug-in later in 
this manual.  
This feature is available in Pro edition. 

New Layer - Add new layer 
 
New Vector Layer - Add new editable vector layer.  
This feature is available in Pro edition. 
Duplicate Layer - Duplicate active layer or layers. 
 
Merge Layers - Merge more layers into one layer. 
 
Remove Layer - Delete active layer or more layers. 
 

 
You can rename an active layer by double-clicking on it in a Layer list. 
You can convert Vector Layer to Bitmap from menu. 
 
Palette, Brushes and Layers Panels are dockable – it is possible to modify, change positions and 
adjust the width of panels.   



The Menu Bar 
 
File - Contains items related to loading, saving, exporting and publishing your paintings. 
Edit - Contains items related to editing the painting process and the canvas. 
Layer - Contains items related to the layers. 
Filter - Contains items related to image filters and effects. 
View - Contains items related to the viewport. 
Window - Contains items related to the user interface. 
Help - Contains items that let you get help on the application, or look for updates on website. 
 
 

File Menu 
 
The File Menu contains items related to your painting. They work as follows: 
 
New... - Open a dialog that allows you to create a new painting with new settings. 
Open... - Open a file dialog that allows you to load a painting from disk. 
Save - Save your painting. If you have not saved it before, you are prompted to enter a name. 
Save As… - Save a copy of your current painting as a new one. 
 
Import… - Open a picture to a new layer. Picture is automatically resized to actual canvas size, 
but it’s possible to move and modify it to any size. 
 
Export layer to SVG… - Export active vector layer as polygons to scalable vector graphics 
format. Set the number of polygons with Detail slider from 1 - 4.  
This feature is available in Pro edition. 

Example: If the vector layer consists of 100 000 polygons and Detail is set to 1, it renders and 
saves 100 000 polygons. If it is set to 2, it quadruples the number of polygons, so the number of 
polygons will be 400 000. If it is set to 3, the number will be 1 600 000. If it is set to 4, the 
number of polygons will be 6 400 000. 
 
Publish… - Publish your painting to Flame Painter Gallery. Enter the name of the painting; 
optionally write a description and tags.  
Publish preferences… - A sub-menu is containing Gallery preferences. 
 
Preferences… - Set Safe Boundary, Wacom Tablet and Leap Motion preferences 
- Safe Boundary - You can set an extended canvas with more visible space than the canvas size. 
Turn on and off a visibility and set a Size and Opacity of a Safe Boundary. 
- Wacom Tablet - Settings for working with tablets which support pen pressure sensitivity. You 
can set intensity of parameters which should be influenced by the pen pressure. 
- Leap Motion - Settings for Leap Motion controller. It allows to paint with using the motion 
control of a hand. Select Shift Key to paint with one finger and use "Shift" key as a mouse 
button, or select Show Two Fingers to paint with two fingers.  

 



Quit - Close the application. (Only on Windows) 
  
For more information on creating, loading and saving your paintings, see the ‘Creating, Loading 
and Saving Paintings’ section later on in the manual. 
 
 

Edit Menu 
 
Undo - Undo the last painting operation you performed. Number of undo-steps depends on 
your computer memory. Maximum number of undo steps is 100. 
Redo - Redo the last operation you undid. 
 
Image Size… - A sub-menu is containing Width, Height of resized image in pixels and Safe 
Boundary in percentage.   
Example: If you create an image with size 1200 x 1200 pixels and Safe Boundary is set to 10%, 
the safe boundary size is 120 pixels. 
 
Check Keep Aspect Ratio if you would like to resize the image with the same aspect ratio as the 
actual picture. 
 
Example: If the actual image width is 1200 pixel and height is 800 pixels and you want to resize 
the image width to 2400 pixels with the same aspect ratio, switch the Keep Aspect Ratio on, 
and application will calculate the remaining dimension - 2400 x 1600 pixels. 

Note: Please make sure you save your artwork before you resize your image. Undo after image 
resize is not available. 
 
Copy - Copy the layer to any third party application which supports image with alpha channel in 
clipboard. 
Paste - Paste image from clipboard (from any third party application) to the layer. 
 
You can also Drag and Drop picture from any application or internet browser directly to Flame 
Painter 3 if the application allows it. 
 
Following tools work with vector layers only, otherwise these options are grayed out.  
These features are available in Pro edition. 
 
Paint Tool - Paint a new brush stroke. You can paint one brush stroke on one vector layer. 
Edit Tool - Edit key vertices (yellow dots) and modify the created vector. Click on vertices (grey) 
to switch them to key vertices (yellow). 
Group Edit Tool - Edit group of key vertices (yellow dots). 
Add & Remove Tool - Remove editable vertices from the flame line. (shortcut: Ctrl on Windows 
/ Cmd on Mac OS) 
Curve Transform - Resize, rotate and scale a brush stroke.  
Init Curve Transform - Resize, rotate and scale an initial curve for brush stroke.  



Layer Menu 
 
New Layer - Add new layer. 
New Vector Layer - Add new vector layer (available in Pro edition).  
Duplicate Layer - Duplicate active layer or layers. 
Merge Layers - Merge layers into one layer. 
Delete Layer - Delete active layer or layers. 
 
Show Layer - Show or hide the active layer. 
Transform Layer - Move and scale active layer. 
Clear Layer - Clear the layer. 
 
Export to Photoshop - Export the layer with layer settings, blending mode and opacity from 
Flame Painter to Photoshop. 
You can find more information about Flame Painter Connect - the Photoshop Plug-in later in 
this manual.  
 
Convert to bitmap - convert vector layer to bitmap layer. This feature is available in Pro 
edition. 
HiRes render... - Set the detail of a High Resolution Renderer (1 - 5). A HiRes Renderer is a 
polygonal renderer. It fills the space between dots and makes the picture smoother without 
the appearance of Moire artifacts. It can be used only with vector layers. 
 
When Hires rendering is finished, the rendered image will replace the current layer. “HQ“ 
appears in the top panel and means “high quality”. When additional edits are made to the 
rendered vector layer, HQ disappears and the vector layer needs to be rendered again.  
 
Press Esc key to cancel the rendering. Please wait till the process stops.  
 
This feature is available in Pro edition. 
 
Note: HiRes renderer is very compute-intensive, it can render a vector layer even few hours. The 
time of rendering highly depends on the length of the brush as well as on the "Size" parameter 
settings. The larger the brush stroke and the size, the longer it takes to render.  

Example: If the vector layer consists of 100 000 polygons and HiRes renderer Detail is set to 1, it 
can render 1 minute. If it is set to 2, it quadruples the number of polygons, so the number of 
polygons will be 400 000 and it will render the layer 4 minutes. If it is set to 3, the number will 
be 1 600 000 and the time will be 16 minutes. If it is set to 4, the number will be 6 400 000 and 
the time will be 64 minutes. If it is set to 5, the number will be 25 600 000 and the time will be 
256 minutes, cca 4 hours. 

 
 
 
 
 



Filter Menu 
 
Blur - Set blur radius from a pop-up window. 

- Preview - Show or hide the result in real time. 
Glow - Set glow radius and strength from a pop-up window. 

- Preview - Show or hide the result in real time. 
 
Tile Layer - Tiles layer horizontally and vertically. 
 
 

View Menu 
 
Zoom In - Zoom in on your artwork (at maximum size of 800%). 
Zoom Out - Zoom out from your artwork (at a minimum size of 5%). 
Zoom 100% - Check up a zoom value. Press the button to reset the zoom to 100%. 
 
Show Cursor - Show or hide a cursor. 
Show Brush Dots - Show or hide brush dots. 
 

Window Menu 
 
Tools - Show or hide a Tools Panel 
Palette - Show or hide a Palette Panel 
Brushes - Show or hide a Brushes Panel 
Layers - Show or hide a Layers Panel 
 
Stay on Top - Application will stay always on a top of other applications. 
Fullscreen - Switch the application window to full screen mode. (Press Esc to quit). 
Show Main Menu - Show or hide a Main Menu (Press Esc to quit). (Only on Windows, on Mac 
OS main menu hides automatically.) 
 

Help Menu 
 
Help - Open this document. 
Send Feedback... - Send us feedback if you have any problem, some idea or just like the 
program. Enter your email and message. 
Flame Painter Website - Link to website: flame.escapemotions.com 
About Flame Painter - Get some basic information on Flame Painter, copyright and credits. 
 
Show Brushes Folder - Show folder where brushes are saved. 
Online Brush Library... - Show online library with downloadable brushes. 
 
Check for updates... - This button is visible when there are new updates available. 
Upgrade to Pro edition - Click if you would like to upgrade from Personal to Professional 
edition. Available in Personal edition. 
  



Flame Painter Connect 
 

Flame Painter Connect is a plug-in for Photoshop CS5, CS6 and Photoshop CC. It is a 
communication channel between Photoshop and Flame Painter 3 Pro for transferring layers 
between these applications. 

Installation 
 

Your installation package contains of 3 folders: 

Mac OS 
Windows 
Photoshop plugin 
 

Installation for Photoshop CS5 & CS5.5 
 
Copy "Flame_Painter_Connect_1.2.swf" file from "Photoshop plugin" folder to Photoshop 
installation folder: 
 
- Windows 32bit: C:\Program Files (x86)\Adobe\Adobe Photoshop CS5\Plug-ins\Panels\ 
- Windows 64bit: C:\Program Files\Adobe\Adobe Photoshop CS5 (64 Bit)\Plug-ins\Panels\ 
- Mac OS: /Applications/Adobe Photoshop CS5/Plug-ins/Panels/ 
 
 
Installation for Photoshop CS6 & CC 
 
STEP 1:  Open “Photoshop plugin” folder and double-click on included 
"Flame_Painter_Connect_1.2.zxp" file. If the file is not associated with Extension Manager 
automatically, open your Extension Manager and choose from menu: File -> Install Extension. 
 
STEP 2:  Extension Diclaimer window opens - click “Accept”. 
 
STEP 3:  A window saying a publisher cannot be verified opens – click “Install”. 
 
STEP 4:  In case you have more Adobe products and extensions installed on your computer,         
a new window may open requiring you to choose the Photoshop version you want a plug-in to 
be installed. 
 
If Extension Manager is not installed on system or plug-in installation is not valid,  
manually copy "Flame_Painter_Connect_1.2.swf" file to Photoshop installation folder: 
 
- Windows 32bit: C:\Program Files (x86)\Adobe\Adobe Photoshop CS6\Plug-ins\Panels\ 
- Windows 64bit: C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\Plug-ins\Panels\ 
- Mac OS: /Applications/Adobe Photoshop CS6/Plug-ins/Panels/ 



How to run Flame Painter Connect 

 

STEP 1:  Run both Photoshop and Flame Painter 3 Pro 

STEP 2:  In Photoshop create new document from 
menu: File -> New... 
 
STEP 3:  In Photoshop click from menu: Window –> 
Extensions –> Flame Painter Connect. A new Flame 
Painter Connect panel on the right side of the screen 
appears. 
 
 

 
 

How to export layers 
 

Export from Photoshop to Flame Painter 

Select a layer that you want to be exported to Flame Painter and click PS to FP button.  
If you select an empty layer in Flame Painter, a layer from Photoshop will be exported to this 
empty layer, otherwise a new layer will be created. 
 
Export from Flame Painter to Photoshop 

Select a layer you want to be exported to Photoshop and click button "PS" in Layers panel, or 
from menu: Layer –> Export to Photoshop (shortcut Ctrl-F for Win, Cmd-F for Mac OS).   
If you select an empty layer in Photoshop, a layer from Flame Painter will be exported to this 
empty layer, otherwise a new layer will be created.  
 
Exported layers keep their original name and opacity. Most of blending modes copy their 
original presets as well. 

 
 

How to keep the same canvas size in Photoshop and Flame Painter 3 Pro 
 
 
Option 1:  Run Photoshop.            

When you export the Photoshop layer, Flame Painter application will be 
opened with the exported layer size.    

 
 
 



Option 2:  Run both Photoshop and Flame Painter 3 Pro.            
When you export the Photoshop layer and there is a New document with no 
changes in Flame Painter, the new document will be resized to the exported 
layer size.  

 
Option 3:  Run both Flame Painter 3 Pro and Photoshop.             

Open Flame Painter Connect in Photoshop. When exporting layer from 
Flame Painter, the new document will be created in Photoshop with 
exported layer size.                      

 
Option 4:  Manually set the same canvas size in both applications. 
 
 
Note: In case the message below appears while working with the Flame Painter Connect, check 
whether both Flame Painter and Photoshop are running. 
 

 
 
If everything is set up correctly, this message might appear while exporting from Photoshop and 
means that it takes too long for Photoshop to process the request. Click “OK“ and wait few 
seconds for the exported image to appear in Flame Painter. 
  



Creating, Loading and Saving Paintings 
 
 

Creating a New Painting 
 
To create a new painting, select the New... option from the File Menu. When you do this, the 
New file panel appears. This panel lets you set the size of your new painting, and set up the 
settings of the canvas you’re going to be painting on. It can be resized during your painting as 
well. In “Picture Size Info” section you can check the picture print size. 
 
The Color Button lets you select the color of the background, including the choice of the preset 
Black or White background.  
 
Finally, click OK to create a new painting, or Cancel if you decide not to. 
 
 

Opening a Painting 
 
To open a painting, select the Open... option from the File Menu. This panel lets you open a 
picture or previously saved artwork and set up the properties.  
 
Finally, click OK to open the painting, or Cancel if you decide not to. 
 
You can also Drag and Drop picture directly from any source - folder, browser or website and it 
opens as a new layer. 
 
 

Saving a Painting 
 
To save your painting, use the Save... option in the File Menu. The native format is a FPA file 
format, which contains all the information about the artwork and the layers. Use this format if 
you want to carry on with the painting later. 
 
With Flame Painter 3 Pro you are able to open and save layered PSD files for Photoshop, Gimp 
or other bitmap programs supporting PSD file format - with all layer settings, blending modes 
and opacity. It’s possible to export vector layers as a SVG vector format file to Illustrator or 
other vector graphics editors, where you can continuously edit your flame picture in vectors. 
 
You can also choose another file formats, please be aware that some of them don't contain all 
the artwork information and may not be opened correctly (background color may be different, 
or transparency might not be saved in JPG format).  
If you wish to save your painting with specific settings or in a form that can be read by other 
applications, use the Save As... option in the File Menu. It allows you to save your painting as a 
PSD, PNG, TIF, BMP, or JPG file.  
 
Finally, click OK to save the painting or Cancel if you decide not to.  



Publish a Painting to Gallery 
 
 

Creating a Gallery account 
 
To publish your artworks, firstly you have to create an account. To create an account you have 
two options:  
 
From application: 
Create your Gallery account from Flame Painter's menu File -> Publish Preferences. Set Your 
name, Email ("Your ID") and Password to gallery and optionally a link to your Website. 
 
From website: 
On the Gallery website press login -> Create Account and enter “Your ID” (registration email). 
We will send you a Password, which you can change later on. 
Note: You can find "Your ID" in Flame Painter's menu Help->About Flame Painter. If "Your ID" 
does not exist, enter your active email. 
 
 

Publish artwork from Flame Painter to Gallery 
 
To publish your painting, use the Publish... option in the File Menu. Enter the Artwork Name, a 
picture Description and Tags. Click Publish button.  Your picture will be published on the 
Gallery website (www.escapemotions.com/gallery) where you can edit pictures later on. 
 
 

Edit your profile and artworks in Gallery 
 
If you have already created an account, go to Gallery website, press login and enter "Your ID" 
and Password. 
In Edit Pictures section you can edit your artworks name, description, tags and other settings. 
In My Profile section you can change your Password. 
 

  

http://www.escapemotions.com/gallery


Keyboard Shortcuts: 
 
    Windows    Mac OS 
 

New...     Ctrl-N     Cmd-N 
Open...    Ctrl-O     Cmd-O 
Save    Ctrl-S     Cmd-S 
Save As...   Ctrl-Shift-S    Cmd-Shift-S 
Import...   Ctrl-Shift-O    Cmd-Shift-O 
Publish...   Ctrl-P     Cmd-P 
Quit    Ctrl-W     Cmd-Q 
 
Undo    Ctrl-Z     Cmd-Z 
Redo    Ctrl-Shift-Z    Cmd-Shift-Z 
Copy    Ctrl-C     Cmd-C 
Paste    Ctrl-V     Cmd-V 
Export to Photoshop  Ctrl-F     Cmd-F 
 

Brush     Q     Q 
Pencil Brush   A     A 
Eraser     E     E 
Fill    F     F 
Transform   T     T 
Edit Vector Layer  V     V 
 

Increase Value +1  Up     Up 
Decrease Value  -1  Down     Down 
Increase Value +10  Pg Up     Pg Up 
Decrease Value -10  Pg Down    Pg Down 
 
Clean Layer   Del     Del 
Move a Canvas   Right Mouse Button or Space Bar + LMB 
 

Zoom In    Ctrl - +     Cmd - + 
Zoom Out   Ctrl - -     Cmd - - 
Zoom 100%   Ctrl - 0     Cmd - 0 
Zoom In | Out   Mouse Scroll or Alt + Mouse Scroll 
 

Quit Hires Rendering  Esc     Esc 
 
Safe Boundary   Ctrl-B     Cmd-B 
Cursor Show | Hide  Alt-C     Alt-C 
Brush Dots Show | Hide  Alt-D     Alt-D 
 
Fullscreen   Ctrl - L     Cmd - L 
Show Main Menu  Ctrl - M     Cmd - M 
Help    F1     Cmd + ? 
Paint Tool   1     1 
Edit Tool   2     2 
Group Edit Tool   3     3 
Add & Remove Tool  4     4 
Curve Transform  5     5 
Init Curve Transform  6     6 



Personal versus Professional Version 
 
 
Personal version is more suitable for users who want to have complete creative tool, but do 
not need to use advanced features and do not sell the pictures created or modified in Flame 
Painter. The license allows installing Flame Painter on multiple computers for single user for 
the personal non-commercial use or non-profit activities. 
 
Professional version is better for professionals and users who need advanced features like 
Vector Layers, HiRes renderer or connection with Photoshop. The license allows installing 
Flame Painter on a one computer for companies; or on multiple computers for single user. This 
license allows to use software for the commercial use or profit activities as well as for non-
commercial activities. 
 
For more details please read the complete Software License Agreement. 
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Translation and corrections: Tanya Hayman, Tony Lloyd, Daniel Streidt, Kenjiro Nagano, 
Higashiuchi Takuri, Kévin Jorand, Marta Fernandez, Irene Briz, Andy Chen, Veronika Klimeková, 
Andrea Vachová 
 
User Interface Icons: "Batch" by Adam Whitcroft 
 
 
Used Libraries: 
 
This application has been developed with the following libraries: 
 
Qt 4.8, LGPL license - http://qt-project.org/downloads/ 
QuaZIP, LGPL license - http://sourceforge.net/projects/quazip/ 
CryptoPP, Boost Software license - http://www.cryptopp.com/ 
ImageMagick, Apache license - http://www.imagemagick.org/ 
AntiGrain Geometry 2.4, LGPL license - http://agg.sourceforge.net/antigrain.com/index.html 
MB WebSockets, LGPL license - https://qt.gitorious.org/qtplayground/mbwebsockets 

 

Thanks to God for all creative ideas. 
  

http://qt-project.org/downloads
http://sourceforge.net/projects/quazip/
http://www.cryptopp.com/
http://www.imagemagick.org/
http://agg.sourceforge.net/antigrain.com/index.html
https://qt.gitorious.org/qtplayground/mbwebsockets


Flame Painter End-User Software License Agreement 
 
 
Copyright 2012-2014 Escape Motions, s.r.o. All Rights Reserved. 
Copyright 2009-2012 Peter Blaškovič. All Rights Reserved. 
 
This license is a legal agreement between you and Escape Motions for the use of Flame Painter 
software (the "Software"). By downloading, installing, copying, or otherwise using the 
Software, you acknowledge that you have read terms and conditions of this license, 
understand them, and agree to be bound by them. If you do not agree with these terms and 
conditions, Escape Motions is unwilling to license the Software to you, and you are not 
authorized and may not use the Software. 
 
 
Permitted Use 
 
Flame Painter Personal: 
 
Users of the Flame Painter may use the Software for personal, non-commercial, or non-profit 
activities. 
You may install the Software on multiple computers provided that not more than one of those 
computers is in use simultaneously and that those computers are solely for your own personal 
use. 
 
Flame Painter Professional: 
 
Users of the Flame Painter may use the Software for commercial, or for-profit activities as well 
as for personal, non-commercial, or non-profit activities. 
The Software may be installed on a computer that is for multiple users but it may not be 
installed on more than one computer regardless of whether those computers are operated 
simultaneously or not. 
You may install the Software on multiple computers provided that not more than one of those 
computers is in use simultaneously and that those computers are solely for your own personal 
use. 
 
You may not remove the copyrights notices from the Software. You may make one (1) copy of 
the Software for back-up or archival purposes. 
 
 
Restrictions 
 
This is a SINGLE COPY SOFTWARE LICENSE. The Software is copyrighted and protected by law 
and international treaty. This is a license, not a transfer of title, and unless you have been 
granted prior, written consent from Escape Motions you may not: 
a, Reproduce, distribute, or transfer the Software, or portions thereof, to any third party. 
b, Sell, rent, lease, assign, or sublet the Software or portions thereof. 



c, Grant rights to any other person. 
d, Modify, decompile, reverse engineer, disassemble, or create derivative works based on the 
Software or the documentation in whole or in part. 
e, Use the Software in violation of any international law or regulation. 
 
You must not intentionally or unintentionally make the Software available on any web server, 
ftp server, file sharing network, shared directory, or other location where any other person can 
acquire a copy of the Software. You are responsible for keeping the Software safe from being 
copied by others. 
 
 
Display of Copyright Notices 
 
All copyright and proprietary notices and logos within the Software files must remain intact. 
 
 
Indemnity 
 
You agree to indemnify and hold harmless Escape Motions for any third-party claims, actions or 
suits, as well as any related expenses, liabilities, damages, settlements or fees arising from your 
use or misuse of the Software, or a violation of any terms of this license. 
 
The Software may contain technical inaccuracies or typographical errors, so changes and/or 
updates may be affected without notice. 
Peter Blaskovic may also make improvements and/or other changes to the Software at any 
time without notice. 
 
 
Disclaimer Of Warranty 
 
THE SOFTWARE IS PROVIDED \"AS IS\", WITHOUT WARRANTY OF ANY KIND, EXPRESSED OR 
IMPLIED, AS TO THE SOFTWARE OR ITS OPERATION, INCLUDING, BUT NOT LIMITED TO, 
WARRANTIES OF QUALITY, PERFORMANCE, NON-INFRINGEMENT, MERCHANTABILITY, OR 
FITNESS FOR A PARTICULAR PURPOSE. FURTHER, PETER BLASKOVIC DOES NOT WARRANT THAT 
THE SOFTWARE OR ANY RELATED SERVICE WILL ALWAYS BE AVAILABLE. 
 
 
Limitations Of Liability 
 
YOU ASSUME ALL RISK ASSOCIATED WITH THE INSTALLATION AND USE OF THE SOFTWARE. IN 
NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS OF THE SOFTWARE BE LIABLE FOR 
CLAIMS, DAMAGES OR OTHER LIABILITY ARISING FROM, OUT OF, OR IN CONNECTION WITH 
THE SOFTWARE. LICENSE HOLDERS ARE SOLELY RESPONSIBLE FOR DETERMINING THE 
APPROPRIATENESS OF USE AND ASSUME ALL RISKS ASSOCIATED WITH ITS USE, INCLUDING 
BUT NOT LIMITED TO THE RISKS OF PROGRAM ERRORS, DAMAGE TO EQUIPMENT, ANY LOST 
PROFITS, BUSINESS INTERRUPTION, LOSS OF DATA OR SOFTWARE PROGRAMS, OR 
UNAVAILABILITY OR INTERRUPTION OF OPERATIONS. 
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